Raspberry, Raspbian und Logitech K400r

Tja. So ein Raspberry ist ruckzuck bespielt und läuft – sogar auf deutsch 🙂

Bei Sparky z.B. gibt es eine kurze und knackige Anleitung:
Raspberry Pi – Erste Schritte (Debian)[1]

Statt nano funzt natürlich genauso joe oder ein anderer Editor; ich selber benutze meistens den Midnight Commander mc samt eingebauten Editor.

Wichtig ist, daß sudo setupcon auf einer echten Console (nicht in einem X-Terminal) ausgeführt wird!

Soweit, so gut.
Schlimm nur, wenn nach dem reboot kein Login mehr möglich ist 🙁
Die Tastatureinstellungen wieder en/us und das benutzte Password enthält Sonderzeichen. … Auf sowas als Ursache kommt man nur, wenn man sicher ist, sich nicht vertippt zu haben – und dann mal kurz ein Sonderzeichen beim Benutzernamen probiert:
Leider zicken manche Bluetooth-Tastaturen. Paradebeispiel:
Logitech K400r –
obwohl meiner Erinnerung nach als voll kompatibel eingestuft!

Bei mir lief das ganze mit dem keyboard type logicd

$ cat /etc/default/keyboard
 # KEYBOARD CONFIGURATION FILE
 # sudo setupcon && sudo reboot on console after Cfg for effect!
 #
 # Consult the keyboard(5) manual page.
 #
 XKBMODEL="logicd"
 XKBLAYOUT="de"
 XKBVARIANT=""
 XKBOPTIONS="compose:lwin,terminate:ctrl_alt_bksp"BACKSPACE="guess"

… erst nach etwas Nacharbeit in der .xsessionrc im User Verzeichnis:
(erstes Kommando erstellt sie, falls noch nicht vorhanden)

$ echo '# deutsche Tastatur unter LXDE' >> .xsessionrc
$ echo 'setxkbmap de' >>  ~/.xsessionrc

Wermutstropfen
Trotz allem kam es bei mir immer wieder vor, daß zwar die Umlaute äöüß usw. funktionierten, aber nicht die dritte Ebene (Alt Gr), die für | (Pipe), \ (Backslash), usw.,  benötigt wird. (Ich hatte u. a. mit den Optionen entsprechend LXDE-Wiki [2] herumgespielt – nur in der Console getippt, nichts in einer Datei wie z. B. .bashrc eingetragen! – und der Müll geistert trotz reboot manchmal noch herum?

Workaround
Daß sich Pipe, Backslash, usw. hier in diesem Artikel trotzdem tippen ließen, ist das Ergebnis eines Workarounds:
Bei laufendem LXDE ein X-Terminal öffnen und dort eintippen:

$ setxkbmap -option
$ exit

Wirkt sofort. Na wenigstens ‚was!
Das Kommando zusätzlich mit in die .xsessionrc mit aufzunehmen bringt übrigens keine Abhilfe! Egal, ob vor oder nach dem „setxkbmap de„.

Saubere(re) Lösung?
Irgendwo hab‘ ich gelesen, daß ein Neuladen des Treiber für die Tastatur (modprobe) die sicherste Lösung sein soll, bis die Treiber für die K400r richtig funktionieren. Diese Tastatur ist leider zu teuer für die Mülltonne 🙁

[Fortsetzung folgt … irgendwann …]

Links:
[1] http://sparky0815.de/2012/06/raspberry-pi-erste-schritte-debian/
[2] http://wiki.lxde.org/en/Change_keyboard_layouts

 

 

This entry was posted in Hardware, IT/EDV, Linux and tagged , , , , , , , , , . Bookmark the permalink.

One Response to Raspberry, Raspbian und Logitech K400r

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

* Die DSGVO-Checkbox ist ein Pflichtfeld

*

Ich stimme zu